re = /\w+(?:\.\w+)+/m
str = 'TD#{test1.test.test3234.rsatars.23432i.rstrsti.arstarst}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end