const regex = /ENERGIA ELETRICA CONSUMO[^%]+%/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ENERGIA ELETRICA CONSUMO[^%]+%', 'gm')
const str = `ENERGIA ELETRICA CONSUMO%
02/2019 347 26/04/2019 305,09 ENERGIA CONS. B.AMARELA kWh 0,54 0,54 29,00% 01/2019 341 11/03/2019 324,39 12/2018 301 26/12/2018 287,83
ENERGIA ELETRICA CONSUMO abc %`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}