import re
regex = re.compile(r"ENERGIA ELETRICA CONSUMO[^%]+%", flags=re.MULTILINE)
test_str = ("ENERGIA ELETRICA CONSUMO%\n"
"02/2019 347 26/04/2019 305,09 ENERGIA CONS. B.AMARELA kWh 0,54 0,54 29,00% 01/2019 341 11/03/2019 324,39 12/2018 301 26/12/2018 287,83\n"
"ENERGIA ELETRICA CONSUMO abc %")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")