const regex = /[Pp]alette[\w, ]+(?:No[ .]+|#)([A-Z0-9]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[Pp]alette[\\w, ]+(?:No[ .]+|#)([A-Z0-9]+)', 'g')
const str = `1. Warehouse A, (Palette #91L41)
2. Warehouse B Palette No. 214
3. Warehouse Lot Storage C (Palette No. 9)
4. Store Location D of Palette (Palette #1)
5. Store Location E of Palette, Empty, lot #45`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}