package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*(B30|A20).*|(C))$`)
var str = `haA20bc
haB30bc
C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}