$re = '/^(.*(B30|A20).*|(C))$/m';
$str = 'haA20bc
haB30bc
C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);