use strict;
my $str = '==Section Header==
===Subsection 1===
# Content begins here.
## Content continues here.';
my $regex = qr/^=+|=+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";