$re = '/^=+|=+$/m';
$str = '==Section Header==
===Subsection 1===
# Content begins here.
## Content continues here.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;