package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:@color\s+)?@fabric(?:\s+@pattern @color)+`)
var str = `@color @fabric @pattern @color @pattern @color`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}