$re = '/(?:@color\s+)?@fabric(?:\s+@pattern @color)+/m';
$str = '@color @fabric @pattern @color @pattern @color';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);