package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[a-zA-Z\.\d]{1})+@\.com`)
var str = `abC.8@com
abC8@@.com
ab.C8@.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}