$re = '/(?:[a-zA-Z\.\d]{1})+@\.com/m';
$str = 'abC.8@com
abC8@@.com
ab.C8@.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);