$re = '/^([^a]|a[^b]*|ab[^c]*)((?:abc)+)(.*)/m';
$str = 'aabcabcabc123_
_abcabcabc123_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);