re = /^([^a]|a[^b]*|ab[^c]*)((?:abc)+)(.*)/m
str = 'aabcabcabc123_
_abcabcabc123_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end