import re
regex = re.compile(r"(.+?)\1+")
test_str = ("0.714285714285714285714285714285714285714285\n"
"0.111111111111111111111111111111111111111111\n"
"0.166666666666666666666666666666666666666666")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")