re = /(.+?)\1+/
str = '0.714285714285714285714285714285714285714285
0.111111111111111111111111111111111111111111
0.166666666666666666666666666666666666666666'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end