package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?:\/\/[^\/]*\/)(.*)$`)
var str = `http://anydomain.com/subfolder/page.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}