re = /^(https?:\/\/[^\/]*\/)(.*)$/m
str = 'http://anydomain.com/subfolder/page.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end