package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-Za-zא-ת\d]+\s(\s[A-Za-zא-ת\d]+)*$)`)
var str = `החבצלת `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}