$re = '/^([A-Za-zא-ת\d]+\s(\s[A-Za-zא-ת\d]+)*$)/';
$str = 'החבצלת ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);