import re
regex = re.compile(r"(?<![a-z'-] )([A-Z][a-z'-]++)[^(A-Z]*\(([^)]+)\)[^A-Z\v]+([A-Z][a-z'-]++)(?!\s[A-Z])[^(A-Z]*\(([^)]+)\)")
test_str = ("[Nisei](slightly scratched) [Ocellaris](unconcious)\n"
"L: 1799 Ocellaris: (slightly scratched) vs. N'isei: (mildly wounded)\n"
"[Nisei](slightly scratched) [Zealot Warrior](perfect condition)\n"
"L: 1799 Ocellaris: (slightly scratched) vs. zealot warrior: (mildly wounded)\n"
"[fire dragon](slightly scratched) [Zealot Warrior](perfect condition)\n"
"[King Jheric](slightly scratched) [Zealot Warrior](perfect condition)\n"
"Me:(condition) v Target:(condition) \n"
"Reply:Some Person L:1200 King Jheric:(condition) vs. Target:(condition)\n"
"[Me] -> (condition) [wolfen berserker] -> (condition)\n"
"Lag: 1200 [zealot warrior](condition) vs. [King Jheric](condition)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")