package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^61-[236]\d{8}$`)
var str = `61-345623456`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}