#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\w* \w*\s\w+"
Local $sString = "nike elite dodge dksaoasd asdojwqd wqe" & @CRLF & _
"тест да пробвам да тествам" & @CRLF & _
"spoasdprtae" & @CRLF & _
"aeqwe "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")