const regex = /(<.*?>)|(<[^>]+>)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<.*?>)|(<[^>]+>)', 'gu')
const str = `This is <strong>very</strong> important.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);