package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[23]?[0-9][0-9]?$`)
var str = `199
200
299
399
400`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}