#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a[^>]+href=[\"|\'](.*?)[\"|\'][^>]*>((?:.(?!\<\/a\>))*.)<\/a>"
Local $sString = "<p>Looking for squeak toys? Check out the <a rel="noopener noreferrer" href="https://www.chewy.com/marvel-s-groot-plush-squeaky-dog-toy/dp/247261" target="_blank" class="onecms-affiliate-link">plush Groot from Marvel's <em>Guardians of the Galaxy</em></a> that's perfect for both play and cuddle time. Cats will surely go wild for the <a rel="noopener noreferrer" href="https://www.chewy.com/star-wars-stormtrooper-plush-mice-cat/dp/247537" target="_blank" class="onecms-affiliate-link">catnip-infused Stormtrooper toys</a>, while dogs that love fetch can <a rel="noopener noreferrer" href="https://www.chewy.com/marvel-s-captain-americas-shield/dp/247164" target="_blank" class="onecms-affiliate-link">chase down Captain America's shield</a>. Those who also want tug toys can grab plush <a rel="noopener noreferrer" href="https://www.chewy.com/pixar-aliens-plush-rope-squeaky-dog/dp/247114" target="_blank" class="onecms-affiliate-link">Pixar's aliens linked on a squeaky rope toy</a>.</p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")