import Foundation
let pattern = #"<a[^>]+href=[\"|\'](.*?)[\"|\'][^>]*>((?:.(?!\<\/a\>))*.)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p>Looking for squeak toys? Check out the <a rel="noopener noreferrer" href="https://www.chewy.com/marvel-s-groot-plush-squeaky-dog-toy/dp/247261" target="_blank" class="onecms-affiliate-link">plush Groot from Marvel's <em>Guardians of the Galaxy</em></a> that's perfect for both play and cuddle time. Cats will surely go wild for the <a rel="noopener noreferrer" href="https://www.chewy.com/star-wars-stormtrooper-plush-mice-cat/dp/247537" target="_blank" class="onecms-affiliate-link">catnip-infused Stormtrooper toys</a>, while dogs that love fetch can <a rel="noopener noreferrer" href="https://www.chewy.com/marvel-s-captain-americas-shield/dp/247164" target="_blank" class="onecms-affiliate-link">chase down Captain America's shield</a>. Those who also want tug toys can grab plush <a rel="noopener noreferrer" href="https://www.chewy.com/pixar-aliens-plush-rope-squeaky-dog/dp/247114" target="_blank" class="onecms-affiliate-link">Pixar's aliens linked on a squeaky rope toy</a>.</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)