use strict;
my $str = 'printf ( ... );';
my $regex = qr/\s*\(\s*([^)]*?)\s*\)\s*/p;
my $subst = '($1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";