$re = '/\s*\(\s*([^)]*?)\s*\)\s*/';
$str = 'printf ( ... );';
$subst = "($1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;