$re = '/(?<=^.{0,3})./m';
$str = '123456
123';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;