const regex = /^(http(s)?:\/\/)(([a-zA-Z0-9_\-])+(\.([a-zA-Z0-9_\-])+)+(:[1-9]+[0-9]*)?)(\/?|((\/(#?[a-zA-Z_\-\.])+)*)(\/?|\?([a-z]+\=([a-z]+|[a-z]+,[a-z]+)*&)*([a-z]+\=([a-z]+|[a-z]+,[a-z]+)*)\/?))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(http(s)?:\\\/\\\/)(([a-zA-Z0-9_\\-])+(\\.([a-zA-Z0-9_\\-])+)+(:[1-9]+[0-9]*)?)(\\\/?|((\\\/(#?[a-zA-Z_\\-\\.])+)*)(\\\/?|\\?([a-z]+\\=([a-z]+|[a-z]+,[a-z]+)*&)*([a-z]+\\=([a-z]+|[a-z]+,[a-z]+)*)\\\/?))$', '')
const str = `http://w.pl:8080`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}