$re = '/^(http(s)?:\/\/)(([a-zA-Z0-9_\-])+(\.([a-zA-Z0-9_\-])+)+(:[1-9]+[0-9]*)?)(\/?|((\/(#?[a-zA-Z_\-\.])+)*)(\/?|\?([a-z]+\=([a-z]+|[a-z]+,[a-z]+)*&)*([a-z]+\=([a-z]+|[a-z]+,[a-z]+)*)\/?))$/';
$str = 'http://w.pl:8080';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);