const regex = /[^\d]2[^\d]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\d]2[^\\d]', 'gm')
const str = `2, 10,11,1,1, 22,1,12,1,1, 1,2 , 2 ,2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}