$re = '/[^\d]2[^\d]/m';
$str = '2, 10,11,1,1, 22,1,12,1,1, 1,2 , 2 ,2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);