package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(:-?[()D])|[^A-Za-z0-9,\s]`)
var str = `Hi, this is good :-D#`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}