$re = '/(:-?[()D])|[^A-Za-z0-9,\s]/m';
$str = 'Hi, this is good :-D#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);