const regex = new RegExp('[a-zA-Z]+\\d+|(?<=\\d)[a-zA-Z]+', 'gm')
const str = `新发布的三星盖乐世S9采用Exynos9810处理器,RAM为4GB,电池容量为3000mAh。
期望将S9,Exynos9810,GB,mAh提取出来
如何将一个句子中的英文词组或者英文+数字词组识别出来
新发布的三星盖乐世S9的特性如下:1.采用Exynos9810处理器;2.RAM为4GB;3.电池容量为3000mAh。
期望将S9,Exynos9810,GB,mAh提取出来,该用什么方法,希望得到各位的指点,谢谢。`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}