use strict;
my $str = 'Hello world, 13th Mar 2020.';
my $regex = qr/(?=(?:[^]{2})+$)/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";