re = /(?=(?:[^]{2})+$)/m
str = 'Hello world, 13th Mar 2020.'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result