$re = '/\\\\index({(?(?!{|})[^\/{}]*|(?1))*})/';
$str = 'Anything before. \\index{{}{}}\\index{Hi}\\anothertag{something}
\\index{}{}
\\index{/}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);