re = /\\index({(?(?!{|})[^\/{}]*|(?1))*})/
str = 'Anything before. \\index{{}{}}\\index{Hi}\\anothertag{something}
\\index{}{}
\\index{/}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end