import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"label\\\":\\\"(?<port>(Eth|eth)[^\\\"]*)";
final String string = "{\"info\":{\"seqno\":0,\"evtType\":1,\"oTime\":null,\"links\":null,\"id\":\"9b0ae9a9-e424-11e9-a309-fd988b74a8c5\",\"origin\":null,\"relations\":[],\"details\":\"\",\"severity\":5,\"time\":1569918148265,\"headId\":\"9b0ae9a9-e424-11e9-a309-fd988b74a8c5\",\"sa\":2},\"desc\":{\"alertId\":{\"desc\":\"The network port is down\",\"label\":\"Link down\"},\"pointId\":[{\"desc\":\"Type: openflow\\nIP: a.b.c.d\",\"label\":\"device_name [a.b.c.d]\"},{\"desc\":\"\",\"label\":\"\"},{\"desc\":\"Network Interfaces\",\"label\":\"\"},{\"desc\":\"\",\"label\":\"eth-0-36\"}]},\"id\":{\"alertId\":\"16\",\"component\":1,\"pointId\":[\"a-b-c-d\",\"dev\",\"1\",\"36\"]}}\n"
+ "{\"info\":{\"seqno\":0,\"evtType\":1,\"oTime\":null,\"links\":null,\"id\":\"4a063431-fb65-11e9-a309-fd988b74a8c5\",\"origin\":null,\"relations\":[],\"details\":\"\",\"severity\":5,\"time\":1572474806370,\"headId\":\"4a063431-fb65-11e9-a309-fd988b74a8c5\",\"sa\":2},\"desc\":{\"alertId\":{\"desc\":\"\",\"label\":\"Link down\"},\"pointId\":[{\"desc\":\"Type: cisco\\nIP: A.B.C.D\",\"label\":\"device-name [A.B.C.D]\"},{\"desc\":\"\",\"label\":\"\"},{\"desc\":\"Ethernet Module\",\"label\":\"\"},{\"desc\":\"\",\"label\":\"Eth1/18\"}]},\"id\":{\"alertId\":\"Link-down\",\"component\":1,\"pointId\":[\"A-B-C-D\",\"dev\",\"1\",\"180000\"]}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}