# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"label\":\"(?<port>(Eth|eth)[^\"]*)"
test_str = ("{\"info\":{\"seqno\":0,\"evtType\":1,\"oTime\":null,\"links\":null,\"id\":\"9b0ae9a9-e424-11e9-a309-fd988b74a8c5\",\"origin\":null,\"relations\":[],\"details\":\"\",\"severity\":5,\"time\":1569918148265,\"headId\":\"9b0ae9a9-e424-11e9-a309-fd988b74a8c5\",\"sa\":2},\"desc\":{\"alertId\":{\"desc\":\"The network port is down\",\"label\":\"Link down\"},\"pointId\":[{\"desc\":\"Type: openflow\\nIP: a.b.c.d\",\"label\":\"device_name [a.b.c.d]\"},{\"desc\":\"\",\"label\":\"\"},{\"desc\":\"Network Interfaces\",\"label\":\"\"},{\"desc\":\"\",\"label\":\"eth-0-36\"}]},\"id\":{\"alertId\":\"16\",\"component\":1,\"pointId\":[\"a-b-c-d\",\"dev\",\"1\",\"36\"]}}\n"
"{\"info\":{\"seqno\":0,\"evtType\":1,\"oTime\":null,\"links\":null,\"id\":\"4a063431-fb65-11e9-a309-fd988b74a8c5\",\"origin\":null,\"relations\":[],\"details\":\"\",\"severity\":5,\"time\":1572474806370,\"headId\":\"4a063431-fb65-11e9-a309-fd988b74a8c5\",\"sa\":2},\"desc\":{\"alertId\":{\"desc\":\"\",\"label\":\"Link down\"},\"pointId\":[{\"desc\":\"Type: cisco\\nIP: A.B.C.D\",\"label\":\"device-name [A.B.C.D]\"},{\"desc\":\"\",\"label\":\"\"},{\"desc\":\"Ethernet Module\",\"label\":\"\"},{\"desc\":\"\",\"label\":\"Eth1/18\"}]},\"id\":{\"alertId\":\"Link-down\",\"component\":1,\"pointId\":[\"A-B-C-D\",\"dev\",\"1\",\"180000\"]}}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.