#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^(\w+([-+.]\w+)*@\w+([-.]\w+)*\.([A-Za-z]{2,4})[;])+$"
Local $sString = "jaga.jkhjk@jkhjkh.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")