$re = '/^(\w+([-+.]\w+)*@\w+([-.]\w+)*\.([A-Za-z]{2,4})[;])+$/i';
$str = 'jaga.jkhjk@jkhjkh.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);