#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)('|")([^\{\}]*)(\#\{([^\}]*)\})([^'"]*)('|")"
Local $sString = "'asdasd #{some} asda asd #{asdasd} ${stuff} asdas as_ $asd#as'" & @CRLF & _
""asdasd #{some} asda asd ${stuff} asdas as_ $asd#as"" & @CRLF & _
"'#{some}'" & @CRLF & _
""#{some}"" & @CRLF & _
""background-image: url(#{cover})""
Local $sSubst = "$1$2$1+$4+$1$5$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)