# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(.?aws/credentials$|.?chef/(.*).pem$|.?gem/credentials$|.?irssi/config$|.?purple/accounts.xml$|.?recon-ng/keys.db$|.?ssh/config$|.?xchat2?/servlist_?.conf$|.agilekeychain$|.asc$|.bek$|.cscfg$|.dayone$|.exports|.extra|.functions|.fve$|.gnucash$|.jks$|.keychain$|.kwallet$|.log$|.mdf$|.ovpn$|.p12$|.pcap$|.pem$|.pfx$|.pkcs12$|.psafe3$|.rdp$|.sdf$|.sqlite$|.tblk$|.tpm$|Favorites.plist|LocalSettings.php|^(.|_)?netrc$|^.*_dsa$|^.*_ecdsa$|^.*_ed25519$|^.*_rsa$|^.?(bash_|zsh_)?aliases$|^.?(bash_|zsh_)?profile$|^.?(bash_|zsh_|sh_|z)?history$|^.?(bash|zsh|csh)rc$|^.?dbeaver-data-sources.xml$|^.?dockercfg$|^.?env$|^.?git-credentials$|^.?gitconfig$|^.?gitrobrc$|^.?htpasswd$|^.?irb_history$|^.?muttrc$|^.?mysql_history$|^.?npmrc$|^.?pgpass$|^.?psql_history$|^.?s3cfg$|^.?trc$|^.?tugboat$|^kdbx?$|^key(pair)?$|^key(store|ring)$|^sftp-config(.json)?$|^sql(dump)?$|carrierwave.rb|config(.inc)?.php$|config/hub$|configuration.user.xpl|credential|credentials.xml|database.yml|doctl/config.yaml$|etc/passwd$|etc/shadow$|filezilla.xml|jenkins.plugins.publish_over_ssh.BapSshPublisherPlugin.xml|journal.txt|knife.rb|omniauth.rb|otr.private_key|password|proftpdpasswd|recentservers.xml|robomongo.json|secret_token.rb|settings.py|terraform.tfvars|ventrilo_srv.ini)"
test_str = (".agilekeychain\n"
".asc\n"
".bek\n"
".cscfg\n"
".dayone\n"
".dockercfg\n"
".exports\n"
".extra\n"
".functions\n"
".fve\n"
".gitconfig\n"
".gitrobrc\n"
".gnucash\n"
".history\n"
".irb_history\n"
".irssi/config\n"
".jks\n"
".keychain\n"
".kwallet\n"
".log\n"
".mdf\n"
".mysql_history\n"
".ovpn\n"
".p12\n"
".pcap\n"
".pem\n"
".pfx\n"
".pkcs12\n"
".psafe3\n"
".rdp\n"
".s3cfg\n"
".sdf\n"
".sqlite\n"
".tblk\n"
".tpm\n"
".trc\n"
".xchat/servlist.conf\n"
".zshrc\n"
"0jbW2b2LzqRm7as9UlgQikgcOcRWeSdz7CCvpNQF/Z3kYXUwQRWD1FT_ed25519\n"
"Favorites.plist\n"
"FkVtMdR9WVKm_ecdsa\n"
"FzimMIicXOStv1VUKm-6ZPnJZJigplLKHXaVGgtsuhdDX_dsa\n"
"Jjc9SMBOYISTlW0TRDX_Tv5QpBsj2tRqP3v1DZNgTLtFnd1UnrX/a4zffCjsJuVvDUYK4_rsa\n"
"LocalSettings.php\n"
"_netrc\n"
"bash_profile\n"
"carrierwave.rb\n"
"chef/8LJ2KnUxkalst.pem\n"
"config.inc.php\n"
"configuration.user.xpl\n"
"credentials.xml\n"
"database.yml\n"
"dbeaver-data-sources.xml\n"
"doctl/config.yaml\n"
"env\n"
"filezilla.xml\n"
"git-credentials\n"
"htpasswd\n"
"jenkins.plugins.publish_over_ssh.BapSshPublisherPlugin.xml\n"
"journal.txt\n"
"kdbx\n"
"keypair\n"
"keyring\n"
"knife.rb\n"
"muttrc\n"
"npmrc\n"
"omniauth.rb\n"
"otr.private_key\n"
"pgpass\n"
"proftpdpasswd\n"
"psql_history\n"
"purple/accounts.xml\n"
"recentservers.xml\n"
"recon-ng/keys.db\n"
"robomongo.json\n"
"secret_token.rb\n"
"settings.py\n"
"sftp-config\n"
"sqldump\n"
"terraform.tfvars\n"
"tugboat\n"
"ventrilo_srv.ini\n"
"zsh_aliases")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.