import Foundation
let pattern = #"(?m)(.?aws/credentials$|.?chef/(.*).pem$|.?gem/credentials$|.?irssi/config$|.?purple/accounts.xml$|.?recon-ng/keys.db$|.?ssh/config$|.?xchat2?/servlist_?.conf$|.agilekeychain$|.asc$|.bek$|.cscfg$|.dayone$|.exports|.extra|.functions|.fve$|.gnucash$|.jks$|.keychain$|.kwallet$|.log$|.mdf$|.ovpn$|.p12$|.pcap$|.pem$|.pfx$|.pkcs12$|.psafe3$|.rdp$|.sdf$|.sqlite$|.tblk$|.tpm$|Favorites.plist|LocalSettings.php|^(.|_)?netrc$|^.*_dsa$|^.*_ecdsa$|^.*_ed25519$|^.*_rsa$|^.?(bash_|zsh_)?aliases$|^.?(bash_|zsh_)?profile$|^.?(bash_|zsh_|sh_|z)?history$|^.?(bash|zsh|csh)rc$|^.?dbeaver-data-sources.xml$|^.?dockercfg$|^.?env$|^.?git-credentials$|^.?gitconfig$|^.?gitrobrc$|^.?htpasswd$|^.?irb_history$|^.?muttrc$|^.?mysql_history$|^.?npmrc$|^.?pgpass$|^.?psql_history$|^.?s3cfg$|^.?trc$|^.?tugboat$|^kdbx?$|^key(pair)?$|^key(store|ring)$|^sftp-config(.json)?$|^sql(dump)?$|carrierwave.rb|config(.inc)?.php$|config/hub$|configuration.user.xpl|credential|credentials.xml|database.yml|doctl/config.yaml$|etc/passwd$|etc/shadow$|filezilla.xml|jenkins.plugins.publish_over_ssh.BapSshPublisherPlugin.xml|journal.txt|knife.rb|omniauth.rb|otr.private_key|password|proftpdpasswd|recentservers.xml|robomongo.json|secret_token.rb|settings.py|terraform.tfvars|ventrilo_srv.ini)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.agilekeychain
.asc
.bek
.cscfg
.dayone
.dockercfg
.exports
.extra
.functions
.fve
.gitconfig
.gitrobrc
.gnucash
.history
.irb_history
.irssi/config
.jks
.keychain
.kwallet
.log
.mdf
.mysql_history
.ovpn
.p12
.pcap
.pem
.pfx
.pkcs12
.psafe3
.rdp
.s3cfg
.sdf
.sqlite
.tblk
.tpm
.trc
.xchat/servlist.conf
.zshrc
0jbW2b2LzqRm7as9UlgQikgcOcRWeSdz7CCvpNQF/Z3kYXUwQRWD1FT_ed25519
Favorites.plist
FkVtMdR9WVKm_ecdsa
FzimMIicXOStv1VUKm-6ZPnJZJigplLKHXaVGgtsuhdDX_dsa
Jjc9SMBOYISTlW0TRDX_Tv5QpBsj2tRqP3v1DZNgTLtFnd1UnrX/a4zffCjsJuVvDUYK4_rsa
LocalSettings.php
_netrc
bash_profile
carrierwave.rb
chef/8LJ2KnUxkalst.pem
config.inc.php
configuration.user.xpl
credentials.xml
database.yml
dbeaver-data-sources.xml
doctl/config.yaml
env
filezilla.xml
git-credentials
htpasswd
jenkins.plugins.publish_over_ssh.BapSshPublisherPlugin.xml
journal.txt
kdbx
keypair
keyring
knife.rb
muttrc
npmrc
omniauth.rb
otr.private_key
pgpass
proftpdpasswd
psql_history
purple/accounts.xml
recentservers.xml
recon-ng/keys.db
robomongo.json
secret_token.rb
settings.py
sftp-config
sqldump
terraform.tfvars
tugboat
ventrilo_srv.ini
zsh_aliases
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)