use strict;
my $str = '<ul>;<li>java</li>;<li>angular</li>;<li>python</li>;
';
my $regex = qr/<[^>]*>|<[^>\/]\/>/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";