$re = '/<[^>]*>/s';
$str = '<ul>;<li>java</li>;<li>angular</li>;<li>python</li>;
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;